1990 KDX 125 No Spark *with an annoying twist!*

Discussion specific to KDX models not sold in the USA
Post Reply
KDX125A
Member
Posts: 4
Joined: 07:40 am Feb 24 2020
Country: United Kingdom

1990 KDX 125 No Spark *with an annoying twist!*

Post by KDX125A » 10:42 am Feb 17 2021

Hi guys, I'm a new member on this forum and would like to say TIA for any useful info shared my way!

I am currently rebuilding an absolute wreck of a '90 KDX125. I almost finished the build and have had it running (albeit not very well) with a '90 KX125 CDI.

When I wired the KX CDI in It produced a fat blue spark and started almost first kick which put a huge :grin: on my face...

However the grin didnt last long because I soon found out (the expensive way!) That the KX CDI isn't compatible, and even tho the CDI would fired the bike up, the timing is wayyy off.

So I purchased a 2nd hand standard CDI from a certain site but I just cannot seem to get Spark with the standard CDI! So frustrating! :snooty:

Any ideas guys? Cheers!

User avatar
KDXGarage
KDXRider.net
KDXRider.net
Posts: 12311
Joined: 06:45 am Nov 01 2004
Country: United States of America
Location: AL, USA
Contact:

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDXGarage » 10:58 am Feb 17 2021

Welcome to kdxrider. Thanks for joining us.

Is the second hand CDI a Kawasaki OEM CDI for a KDX125?

Are you certain it is 100% working properly (not defective)?

Though not easy to find I suppose, I would keep rolling the dice on used stock CDI's until one works properly if the rest of the electrical system is in proper order.
Thank you for participating on kdxrider.net. :bravo:
To post pictures from a device: viewtopic.php?f=88&t=24128

KDX125A
Member
Posts: 4
Joined: 07:40 am Feb 24 2020
Country: United Kingdom

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDX125A » 11:37 am Feb 17 2021

Hi and cheers KDXGarage.

The CDI is indeed a used OEM unit. It is the same unit that is used on a KMX125 also. I was told it was in GWO when purchased, although I do realise it could well be faulty like my last one.

I noticed that the CDI is difficult to check using a multimeter, as the figures seem way off compared to what is said to be the spec figures. The kx125 CDI wouldn't read at all but like I said it fired up almost straight away once fitted on the bike.

Been through and checked the wiring and can't see any issues there...

Really got me.scratching me head on this!

Goofaroo
Gold Member
Gold Member
Posts: 413
Joined: 12:42 pm Sep 09 2012
Country:
Location: Edmond, Oklahoma

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by Goofaroo » 11:42 am Feb 17 2021

Have you checked the spark plug cap on the original coil? If it was running but not very well it could just be that the wire is corroded. Unscrew the plug cap from the wire and see how it looks. Also check the threads on the cap.
If the wire looks corroded clip off about 1/4” and carefully screw the cap back on. If the cap is corroded you can usually find a new NGK cap at Autozone or Oreillys.

It’s worth a shot before you start searching for a new coil.

User avatar
KDXGarage
KDXRider.net
KDXRider.net
Posts: 12311
Joined: 06:45 am Nov 01 2004
Country: United States of America
Location: AL, USA
Contact:

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDXGarage » 11:44 am Feb 17 2021

Autozone or O'reilley's in the UK? LOL

Do check the spark plug wire!

If you can, take the CDI's to a dealer. They have a special CDI checker usually.
Thank you for participating on kdxrider.net. :bravo:
To post pictures from a device: viewtopic.php?f=88&t=24128

Goofaroo
Gold Member
Gold Member
Posts: 413
Joined: 12:42 pm Sep 09 2012
Country:
Location: Edmond, Oklahoma

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by Goofaroo » 11:57 am Feb 17 2021

lol. I have no idea where to get plug cap in the UK.

It may not be his problem but I have fixed a lot of no spark or sporadic spark issues with trimming back the wire or replacing the cap.

User avatar
KDXGarage
KDXRider.net
KDXRider.net
Posts: 12311
Joined: 06:45 am Nov 01 2004
Country: United States of America
Location: AL, USA
Contact:

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDXGarage » 12:08 pm Feb 17 2021

Yeah, I think KDX's are getting into the time phase where that needs to be checked.
Thank you for participating on kdxrider.net. :bravo:
To post pictures from a device: viewtopic.php?f=88&t=24128

Goofaroo
Gold Member
Gold Member
Posts: 413
Joined: 12:42 pm Sep 09 2012
Country:
Location: Edmond, Oklahoma

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by Goofaroo » 12:25 pm Feb 17 2021

Yep. Installing a new plug cap and giving it better purchase on the wire is always a good idea on an older bike.

On Euro bikes that come into my shop with spark issues it’s the first thing I check. If it has a Bosch plug cap it’s the first thing I check. Sometimes all it takes is a NGK cap to get it going again.

KDX125A
Member
Posts: 4
Joined: 07:40 am Feb 24 2020
Country: United Kingdom

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDX125A » 01:11 pm Feb 17 2021

Thanks guys,

I'll contact my local Kawasaki dealer tomorrow and see if they are willing/able to test both the standard CDI units I have.

The coil, plug cap and plug are new so I know that they are fine, plus it started and ran with the KX CDI. The KDX CDI has a lot more going on inside of it in comparison to the KX one, so i guess things are pointing towards that.

KDX125A
Member
Posts: 4
Joined: 07:40 am Feb 24 2020
Country: United Kingdom

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDX125A » 04:25 am Feb 22 2021

Thought I'd close this case off and update everyone that's helped.

I went back through the wiring, which I had to tidy up as the bike was previous VERY neglected and the wiring was a cut and shut bodgery!
Anyway I actually found it to be an earthing issue. I rerouted the earth wire and ground the CDI straight to the frame and HEY PRESTO! I now have spark! 🙂

Now to sort my jetting issues 🤔

Cheers guys.

User avatar
KDXGarage
KDXRider.net
KDXRider.net
Posts: 12311
Joined: 06:45 am Nov 01 2004
Country: United States of America
Location: AL, USA
Contact:

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by KDXGarage » 05:09 am Feb 22 2021

OH good! Congratulations on getting it going. Thanks for the outcome.
Thank you for participating on kdxrider.net. :bravo:
To post pictures from a device: viewtopic.php?f=88&t=24128

Goofaroo
Gold Member
Gold Member
Posts: 413
Joined: 12:42 pm Sep 09 2012
Country:
Location: Edmond, Oklahoma

Re: 1990 KDX 125 No Spark *with an annoying twist!*

Post by Goofaroo » 08:21 am Feb 22 2021

Glad to hear you got your electrical issues sorted. On older bikes that can be a challenge. The mechanical repairs are often much easier than the electrics. The difference between a good running and reliable bike and one with frequent problems is commonly in the wiring.
Time spent cleaning, inspecting, and repairing the harness and ground connections always pay off.

Nice work solving your problem.

Post Reply