Odometer not working

This area is for KDX 200 H series part numbers etc...
Post Reply
Rexann
Member
Posts: 7
Joined: 09:22 am Aug 02 2019
Country: US

Odometer not working

Post by Rexann » 08:27 pm Sep 09 2019

2001 kdx 200 anybody know what could be wrong and how to fix?

User avatar
bufftester
Platinum Member
Platinum Member
Posts: 2402
Joined: 06:03 pm Oct 31 2012
Country: USA
Location: University Place, WA

Re: Odometer not working

Post by bufftester » 10:05 pm Sep 09 2019

Assuming the cable is connected on both ends, put the bike on a stand so the front wheel is off the ground. Unscrew the cable from the bottom of the odometer, and give the front wheel a spin. The inner cable should rotate inside the sleeve. If it does, then the problem is inside the odometer unit. If it doesn't, remove the cable from the front wheel hub and check that the inner cable is not broken by rotating it from both ends. With the cable off you can look inside the hub drive hole and see if the worm gear is moving when you rotate the wheel. If it isn't, then you would need to remove the front wheel and pull the hub drive off to see whats up. Generally its either a broken cable, or the cheap plastic odometer gears inside the unit break.

Rexann
Member
Posts: 7
Joined: 09:22 am Aug 02 2019
Country: US

Re: Odometer not working

Post by Rexann » 08:07 am Sep 10 2019

Ok I’ll give that a try thanks!

User avatar
KDXGarage
KDXRider.net
KDXRider.net
Posts: 9950
Joined: 06:45 am Nov 01 2004
Country: United States of America
Location: AL, USA
Contact:

Re: Odometer not working

Post by KDXGarage » 03:21 pm Sep 10 2019

and be sure that the drive unit was lined up properly during reassembly. There are a couple of tabs in there.
kdxrider.net forum member doakley participating in National Enduro series: (current class standing, 4th!)
viewtopic.php?f=136&t=23217&sid=e6a86d8 ... 9&start=40

Thank you for participating on kdxrider.net. :bravo: To post pictures here: "Full editor", "Attachments", "Add files", select the picture, "Open", "Place inline"

Rexann
Member
Posts: 7
Joined: 09:22 am Aug 02 2019
Country: US

Re: Odometer not working

Post by Rexann » 07:29 am Sep 14 2019

:cool: 👍
KDXGarage wrote:
03:21 pm Sep 10 2019
and be sure that the drive unit was lined up properly during reassembly. There are a couple of tabs in there.

Post Reply