Bike suddenly won't idle?

Got questions? We got answers....
Post Reply
DenverKdxRider
Member
Posts: 10
Joined: 03:11 pm May 04 2020
Country: Japan

Bike suddenly won't idle?

Post by DenverKdxRider » 06:02 pm Aug 01 2020

Hi Everyone,

I bought a JD jet kit put in and per their recommendations ran it at 4th clip, 42 and 158 for the elevation I was at. Was running fantastic (2 days) but towards the end of our trip it just wouldn't idle anymore. Adjusting the air screw and idle knob had no effect. The air filter was a bit dirty but nothing too crazy. I came back home, cleaned the air filter, and cleaned the carb and it still won't idle.

I've recently just cleaned the carb and am dumb founded. The idle screw and air screw have no affect at all on the idle and barely idles then dies. Is the JD jet kit here completely wrong? It's weird that it ran fine then suddenly wouldn't idle. I've heard that it could be the pilot gasket? Is the piston going bad? Any ideas would be appreciated.

User avatar
KDXGarage
KDXRider.net
KDXRider.net
Posts: 11444
Joined: 06:45 am Nov 01 2004
Country: United States of America
Location: AL, USA
Contact:

Re: Bike suddenly won't idle?

Post by KDXGarage » 12:49 pm Aug 02 2020

Did you change elevations during this time?
Thank you for participating on kdxrider.net. :bravo:
To post pictures from a device: viewtopic.php?f=88&t=24128

kdxdazz
Member
Posts: 251
Joined: 07:51 am Dec 28 2017
Country: thailand
Location: Thailand

Re: Bike suddenly won't idle?

Post by kdxdazz » 06:00 am Aug 03 2020

Go back in the carb and recheck everything you did, check the pilot jet isn't loose, check the clip on the needle

DenverKdxRider
Member
Posts: 10
Joined: 03:11 pm May 04 2020
Country: Japan

Re: Bike suddenly won't idle?

Post by DenverKdxRider » 12:15 pm Aug 03 2020

I cleaned my carb by dipping it in parts cleaner which apparently is a bad idea. I am 90% sure that it's my jet block o-ring. I ordered one and gonna replace it. I definitely think that's it because at camp I adjusted the air idle screw and it worked but after it suddenly stopped idling at camp it did nothing. I've checked and rechecked the carb and this seems the culprit.

Post Reply